Live briefing
Everything about Inetd
Unix daemon
inetd is a super-server daemon on many Unix systems that provides Internet services. For each configured service, it listens for requests from connecting clients. Requests are served by spawning a process which runs the appropriate executable, but simple services such as echo are served by inetd itself. First appearing in 4.3BSD, it is generally located at /usr/sbin/inetd. inetd is based on the (service) activator pattern Wikipedia →
đź§ Start here: a 6-step reading path
- Read the overview: InetdA 5-minute orientation
- Pick up a classic book: Hacking Linux exposedThe most-reprinted book on the subject
- Go sideways: XinetdA closely related topic
- Go sideways: Echo ProtocolA closely related topic
đź“– Definitions
No dictionary entry for this exact phrase.
🗂️ The subject at a glance
🏆 Landmark papers (most cited)
- No matching papers found.
📚 Books worth reading
Hacking Linux exposedBri Hatch, James Lee · 2001
Ranked by number of editions on Open Library, a rough measure of how lasting a book is.
đź”— Related topics
- Xinetd In computer networking, xinetd (Extended Internet Service Daemon) is an open-source super-server daemon which runs on many Unix-like systems, and manages…
- Echo Protocol The Echo Protocol is a service in the Internet Protocol Suite defined in 1983 in RFC 862 by Jon Postel. It was originally proposed as a way to test and…
- Daytime Protocol The Daytime Protocol is a service in the Internet Protocol Suite defined in 1983 in RFC 867 by Jon Postel. It is intended for testing and measurement purposes…
- Character Generator Protocol The Character Generator Protocol (CHARGEN) is a service of the Internet Protocol Suite defined in RFC 864 in 1983 by Jon Postel. It is intended for testing…
- Discard Protocol The Discard Protocol is a service in the Internet Protocol Suite defined in 1983 in RFC 863 by Jon Postel. It was designed for testing, debugging, measurement…
- Time Protocol The Time Protocol is a network protocol in the Internet Protocol Suite. Its purpose is to provide a site-independent, machine readable date and time. The…
- Port (computer networking) In computer networking, a port is a communication endpoint. At the software level within an operating system, a port is a logical construct that identifies…
- Berkeley sockets Berkeley sockets is an application programming interface (API) for Internet domain sockets and Unix domain sockets, used for inter-process communication…