Everything about Token Binding
Extension for Transport Layer Security
Token Binding is a proposed standard for a Transport Layer Security (TLS) extension that aims to increase TLS security by using cryptographic certificates on both ends of the TLS connection. Current practice often depends on bearer tokens, which may be lost or stolen. Bearer tokens are also vulnerable to man-in-the-middle attacks or replay attacks. In contrast, bound tokens are established by a user agent that generates a private-public key pair per target server, providing the public key to the server, and thereafter proving possession of the corresponding private key on every TLS connection to the server. Wikipedia →
🧭 Start here: a 6-step reading path
- Read the overview: Token BindingA 5-minute orientation
- Skim a recent paper: Abstract 981: MTA-DTA: A multi-token attention framework for drug-target binding affinity predictionInfluential work since 2022
- Pick up a classic book: الذي سيتم القيام به؟The most-reprinted book on the subject
- Read the landmark paper: Token Binding & Context-Aware JWT Enforcement: A Secure Identity-Aware Token Validation Framework For Modern Distributed SystemsCited 0 times
- Go sideways: Transport Layer Security Channel IDA closely related topic
- Go sideways: OAuthA closely related topic
📖 Definitions
No dictionary entry for this exact phrase.
🗂️ The subject at a glance
🏆 Landmark papers (most cited)
🆕 Influential since 2022
📚 Books worth reading
الذي سيتم القيام به؟Mark Grant Davis · 2014
IEEE standard for information technologyInstitute of Electrical and Electronics Engineers · 1991
The C# programming languageAnders Hejlsberg, Scott Wiltamuth · 2004
Understanding object-oriented programming with JavaTimothy Budd · 1998
Seamstress and poetFelicia Ross Johnson · 1907
Programming Language PragmaticsMichael Lee Scott · 2009
Drita e kohës së reProf. dr.Sejfedin Sulejmani · 2007
Introduction to making very big booksUnited States. Congress. Senate. Committee on Pensions · 2011
Ranked by number of editions on Open Library, a rough measure of how lasting a book is.
🔗 Related topics
- Transport Layer Security Channel ID Transport Layer Security Channel ID (TLS Channel ID, previously known as Transport Layer Security – Origin Bound Certificates TLS-OBC) is a draft RFC proposal…
- OAuth OAuth (version 1: RFC-5849, version 2: RFC-6749; sometimes incorrectly extended to open authorization) is an open standard for access delegation, commonly…
- Transport Layer Security Transport Layer Security (TLS) is a cryptographic protocol designed to provide secured communications over a computer network, such as the Internet. The…
- Extensible Authentication Protocol Extensible Authentication Protocol (EAP) is an authentication framework frequently used in network and internet connections. It is defined in RFC 3748…
- Cipher suite A cipher suite is a set of algorithms that help secure a network connection. Suites typically use Transport Layer Security (TLS) or its deprecated predecessor…
- Simple Authentication and Security Layer Simple Authentication and Security Layer (SASL) is a framework for authentication and data security in Internet protocols. It decouples authentication…
- Salted Challenge Response Authentication Mechanism In cryptography, the Salted Challenge Response Authentication Mechanism (SCRAM) is a family of modern, password-based challenge–response authentication…
- FTPS FTPS (also known as FTP-SSL and FTP Secure) is an extension to the commonly used File Transfer Protocol (FTP) that adds support for the Transport Layer…